简单方式安装/升级/切换node版本的方法:n & nvm

前天对博客的样式进行了一点修改,顺道把之前因年幼无知没有ignore掉的 node_modules/ 目录删掉了。

然后去服务器git pull,因为时间急迫赶着下班,node_modules/ 目录里文件太多,没pull完就把电脑合起来了。结果捏,broken pipe,需要重新 npm install

然后理所应当的npm install失败了。原因是npm版本低于3.0.0

我TM又把自个儿服务器整宕机了。

那就要升级npm咯。查了下node版本,4.2.2,也低了点,反正npm跟node是绑定的,一起把node升级了算。

做了一下调研,正常的方式是下载最新版本,编译安装。最简单的方式是:n。最合适的方案是:nvm

去他的编译安装!

n

n的使用方式很简单,所以我把它用到了我的服务器上。只需要安装一下就可以了。

$ npm install n -g

然后用此命令安装目前的稳定版:

$ n stable

也可以安装指定版本:

$ n [version]

例如:

$ n v7.2.0

就这么简单。。

nvm

nvm其实就是node version manager啦。nvm安装稍微麻烦点,但比n更加好用,可以预先安装好各个版本的node,随时切换。所以我将其用在了工作环境和自己的windows电脑上。

安装需要有很多要遵守的规定和环境,比如c++编译环境啦之类。篇幅过多不在此赘述,可以去这里(nvm的github)看,本身不难。

安装好以后,就可以这么用了:

nvm使用

$ nvm install stable #下载、编译、安装当前的稳定版
$ nvm install v7.2.0 #安装v7.2.0版本

在nvm里,你可以安装老多个版本的node,随时切换:

$ nvm use v5.2.1 #使用v5.2.1版本的node

你可以把已经安装的node版本列出来:

$ nvm list #列出来

也可以不切换,直接运行一个版本的node命令行:

$ nvm run v4.2.2 #运行v4.2.2

只是说了一些基本用法,也够用了。其他的可以自己试一试。

真的很好用!解决了痛点有木有!老项目散发第二春有木有!



评论

暂无评论

在这里输入